0

I am using a Mac OS High Sierra, version 10.13.6.

While installing the more recent version of QGIS, I ran into a popup that said "Failure, The GDAL 2.3 framework is required."

Naturally, I opened up terminal, and entered tried to bash install GDAL, but it doesn't appear to be working.

sudo pip3 install GDAL

gives me

Command "python setup.py egg_info" failed with error code 1 in /private/tmp/pip-install-g7dpscpt/GDAL/

Does anyone know why this is?

  • Seems like GDAL isnt installed, did you read the readme? Pretty sure you need to install Python first, then GDAL, then QGIS. All the installers come in the dmg if i remember correctly – JamesLeversha Nov 8 '18 at 2:10
0

You may try more user friendly installer without readme and other instruction for advanced users. Just next -> next -> finish. But in this installer only previous QGIS LTR present - 2.18.25. You can get installer here: http://nextgis.com/nextgis-qgis/

There is autoupdate tool in this installer, so as soon 3.x version will be ready, notification will popup.

Disclaimer: I'm developer at NextGIS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.