3

How do I change the font in the processing script editor? I loaded 3.4 today and it works, but the font in the editor is not set to a monospace font for English, making spaces and positions extremely confusing. I would like to change it to a standard monospace font. I only see a size control in the editor, and I don't see anything in the main QGIS options list.

Update: I installed the mac version, and it has the same problem. This is pretty awful. It wouldn't be a big deal, but the QGIS team doesn't seem to have planned in support for external IDEs. Here's a pic.

weird font problem in QGIS 3.4 script editor

  • Does it help to change the default font used by QGIS in the Settings menu > options > general? – csk Nov 8 '18 at 19:39
  • @csk nope. switched font from Qt default to Segoe UI, but this just affects the interface not the editor. – auslander Nov 8 '18 at 20:03
  • 1
    @Joseph thanks, that worked. When I set it to Consolas it did fix the spacing issue, at least on Windows. I'll check later this evening when I'm in front of the mac. If you want to post this as an answer, I'll give it the green checkmark. – auslander Nov 9 '18 at 14:47
  • @auslander - Most welcome, glad it helped. Thanks, will post the comment as an answer for the convenience of others :) – Joseph Nov 9 '18 at 14:59
2

You can change the font of the script by opening the Python Console and then clicking the Options icon. Go to the Editor tab and change the font.

This will change the script editor font.

  • 1
    Just a clarification I found; this will affect the editor that loads in the Python Console, but it will not change the standalone editor launched from the Processing Toolbox menu. My feeling is that this would be a reportable issue in the QGIS issue tracker, but is certainly good enough of a solution to close out the question. – auslander Nov 9 '18 at 16:36
  • 1
    Just for the sake of completeness: It seems to me that this bug report: issues.qgis.org/issues/20349 addresses this issue – christoph Nov 30 '18 at 8:48
  • 1
    @christoph - Thanks for the comment, it seems the issue has been fixed now :) – Joseph Nov 30 '18 at 10:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.