I cannot open the Georeferencer in both Qgis 3.0.2 Girona and 3.2.3 Bonn. The plugin worked fine in both 3.x versions until today. It still work in version 2.18.24.

It doesn't seem to open any windows at all, so I don't think it is an issue of windows being in another screen as in some other case. I also had a look at solution suggested here: http://gis.stackexchange.com/questions/83334/georeferencer-plugin-will-not-load-in-qgis , but they do not apply to my case since I do not have a "Plugin-GeoReferencer" folder in my registry for versions 3.x.

Reinstalling did not solved the issue for qgis 3.2.3

any ideas of how to fix the problem?

+++ UPDATE +++

Same problem with the just installed 3.4 MAdeira version

  • Did you try updating and enabling the plugin through the plugin manager? If that doesn't work, what happens when you try?
    – csk
    Commented Nov 8, 2018 at 19:55
  • I had the idea myself but the plugin manager says that the georeferencer is part of the core code (or something similar) and the buttons (install, uninstall, update) are greyed out... so I don't know how to updat the plugin.
    – Filippo
    Commented Nov 8, 2018 at 20:00
  • 1
    Right, I forgot about that. Is it enabled (the check-box next to the plugin name should be selected)? gis.stackexchange.com/a/274566/81764
    – csk
    Commented Nov 8, 2018 at 20:26
  • Yes, it is enabled
    – Filippo
    Commented Nov 8, 2018 at 20:33
  • 2
    are you working with 2 screens ?
    – Leehan
    Commented Nov 9, 2018 at 12:33

2 Answers 2


Problem Solved:

I have been using 2 different second screens: one at home added as left screen, and one at work as right screen.

When I posted my question yesterday I was using the screen at work (so on the right), but possibly the last time I used the georeferencer I was at home so that the windows could have been open on the left screen.

I didn't think the 2 screens were the problem because when launching the georeferencer, I did not see any new window opened neither in the task bar nor when doing ALT+Tab (i'm on windows10). However, now I realize that that is the normal behavior of Qgis (i.e. it opens a windows that is not seen elsewhere but the screen).

Once at home, I tried again to use the georeferencer on a 3.x version and this time the windows popped up in the second screen (on the left). At that point I moved it on the main screen of my laptop and that was enough to see it today at work.

Clearly not a behavior that one should expect... but solved.

thanks @csk and @Leehan


Happened the same here, but the screens were one above the other one. Switched them and the georeferencer appeared.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.