0

I have two raster layers with a count and value in the attribute table but when I try to reclassify with count and equal interval quartiles the classification reverts back to "value" in the symbology. I need to be able to get the symbology to be based on count and not value. This is important because I need to create a new layer such that only the highest quartiles from the 2 layers are shown.

How can this be accomplished?

Regarding previous operations I needed to specify certain land cover features such that water was removed so I used a reclassify and then ascribed nodata to water...

then I used a extract by mask so the DEM layer also removed water.

Then I performed 2 different hillshades with different azimuth and altitudes and these layers are what need to be classified correctly so they can be added.

  • Welcome to GIS SE! We're a little different from other sites; this isn't a discussion forum but a Q&A site. Please check out our short tour to learn about our focussed Q&A format. What are the precise steps (all tools, all parameter values) that you perform to see this software behaviour? – PolyGeo Nov 13 '18 at 8:14
  • edited to include previous steps – shibu Nov 13 '18 at 8:30
1

If you want to classify based on COUNT Field you cannot do it directly. You need to add a new field name it COUNT_2 for example and copy the values from COUNT field. This will enable the selection of field to apply the symbology:

Without adding new COUNT field, the selection of attribute is inactive:

enter image description here

After adding COUNT_2 field it becomes active:

enter image description here

  • thanks for this... can I ask what exactly is count then in regards to hillshade? – shibu Nov 13 '18 at 8:49
  • @shibu the values of hillshade do not reflect elevations, they are just pixel values that range from 0 to 255 which provide illustration of the topography based on sun position. The count column (field) calculates the number of pixels that have the same digital number (DN) values in the Value field. – ahmadhanb Nov 13 '18 at 9:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.