2

I am trying to import a CSV file with Lat Long values I geocoded in Google Earth into QGIS, and I'm getting some very strange results.

A well-formatted decimal-degree Lat/Long pair (like 30.402716, -88.867475) gets translated into a tiny tiny XY pair like (-0.0008,0.0003). The points show up basically in the right position relative to each other, but these decimal values are way off relative to my other layers, why is this decimal conversion happening and why is it so wrong?

I'm using the "Create Layer from Delimited Text" dialogue, and I set X to Long, and Y to Lat, and selected the CRS to Google Maps Global Mercator EPSG:900913

Lat Long problem

4

If they're truly lat/lon coordinates, set the CRS to EPSG:4326 and see if that helps. If you want EPSG:900913, you'll need to ("re")project them.

2
  • Yep that did the trick! Thanks @Jon .... I still don't understand what is going on with weird decimal conversion, is there something wack with EPSG:900913? – Justin Kray Nov 14 '18 at 2:28
  • 3
    @JustinKray, EPSG:900913 uses metres as it's horizontal coordinates units, not decimal degrees. – user2856 Nov 14 '18 at 3:32
2

To save someone else the time and aggravation of doing this incorrectly, I'd like to clearly point out that when importing XY data, the Geometry CRS (of the data you're importing) needs to be set to EPSG:4326 (WGS 84). My project (and default) CRSs are set to the standard for my locality; you just need to be sure to set the data import CRS to EPSG:4326. The data should come in looking correct, but you should (always) run Reproject layer to set the imported data to your desired projection.

I'd like to add that when importing data with UTM coordinates, you SHOULD set the Geometry CRS to your desired end CRS (at least that's how it worked for me; setting it to EPSG:4326 put the data out in the middle of nowhere).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.