1

I was working on two different layers which I ultimately combined together using the "union" tool. However, I now have twice the information in the attribute table as shown in the picture. Any insight on how I can quickly delete the repeated rows? enter image description here

1

As each row represents a feature, it looks like you have duplicated some of your features. If these features have identical geometry (ie you didn't edit the geometry in one file and not the other - and that explains why you appear to have half the number of features in the map as they sit directly one on top of the other), you can go:

MMQGIS->Modify->Delete Duplicate Geometries

You may need to install the MMQGIS plugin via Plugins->Manage and install plugins...

You can also type 'duplicate' into the Prcoessing toolbox search bar and you will find another couple of tools that do the same thing.

1

Another option (a bit rudimentary maybe, but very simple) could be to create a new field, let's name it "num" for example, Just put $rownum as the expression. Then, go to Select by expression and type: "num" % 2 = 1 It will select the uneven rows. Then, click edit, and delete selected objects. In your case as I see the repetition is alwas the same (each feature repeated once) this should work.

  • 2
    This is a risky strategy, you may end up deleting data you should have kept. Be sure to take a close look and make sure you don't need those rows before deleting. – csk Nov 14 '18 at 17:10
  • You are right. But this strategy works if, as it looks like, each row is doubled with no exceptions. In any case, of course is important to take a close look before deleting. Thanks! – Alex Fernández Poulussen Nov 14 '18 at 17:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.