1

I am using GeoServer 2.13.2 with netcdf data from ECMWF and all is working fairly well with a fixed extent. As soon as I turn on Map Wrapping (wrapx) in OpenLayers (5.x) then contours, wind barbs, and wind arrows do not wrap. They seem stuck in the source data extent. Please note the following settings in GeoServer:

enter image description here

Please note that Layer Preview contours wrap fine on GeoServer so now I know it is setting on client side, but I can't see any difference in my WMS vs their preview. See image of preview:

enter image description here

On second thought the Layer Preview is not working fine. If I pan left then Contour rendering starts to have issues so it has to be on GeoServer side: enter image description here

Why is it working some times and not others based on panning? In fact it gets worse the further you pan left or right. I don't know if it is issue in GeoServer or OpenLayers. See image when I pan further right: enter image description here

How do I solve it?

Sample picture attached. enter image description here

closed as off-topic by Andre Silva, Kadir Şahbaz, LaughU, whyzar, Jochen Schwarze Apr 8 at 14:09

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions that relate to the business of vendors and product teams, such as licensing, pricing, release dates, submission of bug reports and enhancement requests, etc, are off-topic here and should be directed instead to the official software support teams." – Andre Silva, Kadir Şahbaz, LaughU, whyzar, Jochen Schwarze
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Vector Tiles for raster data? Doesn't make sense. Furthermore, on OpenLayers wrapx works well for BingMaps and is not available for ImageLayer/ImageWMS although as can be seen in the image above it does work as it seems to be extent related. The only thing that does not wrap are the contours. – Gregory Turner Nov 17 '18 at 16:05
  • 2
    I'm not sure that the "advanced projection handling" machinery works with rendering transformations, it might well not (haven't checked the code, but going by memory, it does not). – Andrea Aime Nov 21 '18 at 9:27
  • 1
    @AndreaAime, Your contact page link is broken. Please PM me on cost of starter and basic plans. – Gregory Turner Dec 19 '18 at 23:29
  • 1
    I don't work the commercial side of things, just a techy. You can inquire here: geo-solutions.it/contacts – Andrea Aime Dec 20 '18 at 8:43
  • 1
    I see that it is still not fixed in 2.15.0. That is too bad as Geoserver is in general a very nice map server. It seems that the ncWMS guys have solved this problem. Maybe you can get together with them on the rendering to solve it. – Gregory Turner Mar 26 at 14:08