0

I have a polyline shapefile that's about 200,000 meters long, and I am trying to get xy coordinates for specific distances along the line.

The polyline shapefile is in UTM coordinates. I ran the Create Routes tool on the polyline. Then, I tried the Make Route Event Layer tool. Screenshots below show the inputs. No issues/warning flags with selecting route fields, etc. A snapshot of the text table is below. The distances are not uniform (although the first few shown here are an even 500 m apart). Upon running the Make Route Event Layer tool, the resultant point events has "ROUTE NOT FOUND," and so there are no points generated along the line (or anywhere in space for that matter). I don't understand why it's not placing my points at the distances along the polyline route.

Dist_km Dist_m
0   0
0.5 500
1   1000
1.5 1500
2   2000

Create Routes Tool Inputs Make Route Event Layer Tool Inputs Resultant Point Events

  • I suggest to read Linear referencing essential vocabulary first. desktop.arcgis.com/en/arcmap/10.3/guide-books/… – FelixIP Nov 18 '18 at 2:29
  • I would also suggest using a RouteID field other than the OBJECTID field. Just create another ID field called RouteID, calculate your OBJECTID into it, and use that when you create your routes. I'm assuming that is why you are pointing the CreateRouteEvent tool to OBJECTID2, but that is not necessarily the actual RouteID. – JonR Nov 29 '18 at 19:49
  • You also need an ID in your Route Event Table that has the actual Route ID. The table sample you provided does not; it only has two distance measures (in m and km). – JonR Nov 29 '18 at 19:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.