I want the title of a legend in the print composer to be in bold font. If I change the font to be italic in the item properties font dialog the output becomes italic but if I change it to bold it does not change. I have tried numerous font types.

I am using QGIS 2.18 on macOS High Sierra 10.13.6. I have enabled bold layer names in the print composer settings.

What can be the problem?

  • 1
    Try to change the font itself. Some fonts do not support bold style.
    – ahmadhanb
    Commented Nov 18, 2018 at 20:26
  • I tried numerous font types including typical ones like Arial, Helvetica and Times New Roman but they all don´t work.
    – Guest
    Commented Nov 18, 2018 at 20:34

1 Answer 1


This is very simple. Add your text you need to use as HTML Use the bold tag as seen here https://www.w3schools.com/html/html_formatting.asp

<b> - Bold text
<strong> - Important text
<i> - Italic text
<em> - Emphasized text
<mark> - Marked text
<small> - Small text
<del> - Deleted text
<ins> - Inserted text
<sub> - Subscript text
<sup> - Superscript text

And then choose render as html. You can do some fancy labeling with html. You can even color code each letter of the label as opposed to the label options which act on the whole string

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.