4

I have a SQLite database which I have just created in QGIS and I want to open it in ArcGIS Pro.

In Catalog I have added the database to the project but when I try to add layers to the map I get the error "Exception from HRESULT: 0x80041538".

I want to have a common source of data for QGIS and ArcGIS Pro if possible so using a different format is not ideal.

5
  • 2
    GeoPackage (also a SQLite database) will probably work better as a common format.
    – user30184
    Nov 20, 2018 at 11:22
  • @user30184 - Can you expand on why that is? Nov 20, 2018 at 11:29
  • 1
    Clarify first what do you exactly mean by SQLite database. Do you mean SQLite with Spatialite geometries?
    – user30184
    Nov 20, 2018 at 17:32
  • Yes. Data which I exported from QGIS as Spatialite. Nov 21, 2018 at 9:07
  • 2
    If your goal is just to have a common data-source between ArcMap and QGIS you may have more luck by using a file geodatabase (ESRI product will obviously work well with it and you can enable QGIS to have read/write capability by installing the ESRI FileGDB driver,for more read this : gis.stackexchange.com/questions/26285/…
    – J.R
    Nov 10, 2020 at 8:59

2 Answers 2

0

SQL Lite is supported in ArcGIS Pro by creating a connection to a folder and viewing it through the Folder node. (Not by creating a database connection as you've said you've done). You will interact with it much like you would a file geodatabase (fgdb)

Reference: https://pro.arcgis.com/en/pro-app/help/data/databases/work-with-sqlite-databases-in-arcgis-pro.htm

1
  • 1
    Since I do not yet have the reputation to comment - but the issue endures: The solution posited by @KHibma does not work. The issue experienced by OP manifests itself with large datasets (several million rows +). The issue tends to also occur with datasets generated from QGIS, including the most recent 3.10, and ArcGIS Pro 2.4.3
    – anakaine
    Nov 4, 2019 at 0:45
0

I can also confirm that I am experiencing this issue. I have a geopackage database, which has a table inside it, containing no geometry. Attempting to add this table into ArcGIS Pro, either using the Database/file navigation method fails.

The only difference is that i receive a slightly different error code. Exception from HRESULT:0x8004152F

I can add other tables from that database, but no the non-geometry table. Am using ArcGIS pro 2.4

1
  • 1
    I got this same error (HRESULT:0x8004152F) in Pro 2.4. When I tried loading the file using Pro 2.6 it warned of an unknown coordinate system, but otherwise loaded fine. Sounds like the lack of a coordinate system is why you're having problems loading the non-geometry table, but that Pro 2.6 might be a solution. Jan 15, 2021 at 14:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.