0

Wile I was trying to amateurish solve the problem of that post: QGIS 3.4.1 crash without error after opening "options" (18.04. Bionic Beaver) I got a new, much more dramatic problem:

/usr/lib/qgis/crssync: error while loading shared libraries: libqgis_core.so.3.4.1: cannot open shared object file: No such file or directory

I purged, autoremoved, installed and uninstalled, changed the repositorys, reconfigured and so on... But I have no glue, what to do next. I just need to get QGIS3 running and have no time to re-setup my system!

Where do I get the libqgis_core.so.3.4.1? Google isn't telling me...

UPDATE: result after trying to install via 'sudo apt-get install qgis python-qgis qgis-plugin-grass':

>     Setting up qgis-providers (1:3.4.1+28bionic) ...
>     /usr/lib/qgis/crssync: error while loading shared libraries: libqgis_core.so.3.4.1: cannot open shared object file: No such file or
> directory
>     dpkg: error processing package qgis-providers (--configure):
>      installed qgis-providers package post-installation script subprocess returned error exit status 127
>     dpkg: dependency problems prevent configuration of qgis:
>      qgis depends on qgis-providers (= 1:3.4.1+28bionic); however:
>       Package qgis-providers is not configured yet.
>     
>     dpkg: error processing package qgis (--configure):
>      dependency problems - leaving unconfigured
>     dpkg: dependency problems prevent configuration of qgis-plugin-grass:
>      qgis-plugin-grass depends on qgis (= 1:3.4.1+28bionic); however:
>       Package qgis is not configured yet.
>     
>     dpkg: error processing package qgis-plugin-grass (--configure):
>      dependency problems - leaving unconfigured
>     No apport report written because the error message indicates its a followup error from a previous failure.
>                                                                                                               No apport report written because the error message indicates its a
> followup error from a previous failure.
>                                                                                                                                                                                                                         Errors were encountered while processing:
>      qgis-providers
>      qgis
>      qgis-plugin-grass
>     E: Sub-process /usr/bin/dpkg returned an error code (1)
  • what installation instructions were you using? – DPSSpatial Nov 20 '18 at 18:46
  • That one from qgis.org using the qgis.org/ubuntu/ repository for 3.4.1 LR: qgis.org/de/site/forusers/alldownloads.html#debian-ubuntu – MAP Nov 20 '18 at 18:59
  • What about sudo apt-get install qgis python-qgis qgis-plugin-grass? – Zoltan Nov 20 '18 at 19:56
  • I was finally forced to re-setup my whole system... problem solved so far... – MAP Nov 26 '18 at 9:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.