2

I'm using QGIS 3.4.1 on Windows. I am trying to use a point vector source from a public authority with OpenStreetMap data, but the points do not align with their expected locations.

Try the following:

  1. Create a new project.
  2. From the browser, go to the XYZ Tileserver category and add the OpenStreetMap layer to the project.
  3. Zoom in to Berlin, Germany.
  4. In the browser, right-click on WFS and choose "New connection..."
  5. Enter https://fbinter.stadt-berlin.de/fb/wfs/data/senstadt/s_messpunkte in the URL field, name the layer "emissions" (these are air quality testing stations) and click "OK".
  6. Add the layer from the provider to the project (Entwicklung Luftqualität - Immissionen (Umweltatlas))

The default CRS is EPSG:4326, the OSM "CRS" is EPSG:3857 and the CRS of the point layer with the air quality testing stations is EPSG:25833. (After adding the OSM data, the project's projection changes to EPSG:3857, as expected.)

The emissions layer seems to be displaced. Consider the point (1493533,6893411) in the emissions layer (the top point in the image below). Taking the OSM image as a reference, this point should actually be at (1493539,6893156) (roughly where the bottom point is).

enter image description here

Why are these layers not aligned? The potential causes I have considered are:

  1. EPSG:3857 is incompatible with the CRS (EPSG:25833 - ETRS 89 UTM Zone 33N) of the point layer. But I pulled a set of street data from the same provider (which uses the EPSG:25833) and it is reprojected so that it accurately matches the streets in the OSM data.
  2. I have a poor combination of CRS and/or am using the wrong CRS for the project.
  3. The data source ("emissions") is somehow broken.
  4. There is a bug in QGIS :P

This installation is using proj 5.2.0 and GDAL 2.3.2.

  • 1
    Is Enable 'on the fly' CRS Transformation checked under the project properties-CRS? – GBG Nov 21 '18 at 19:41
  • 1
    Same here. Maybe you should ask the data provider about it. – AndreJ Nov 21 '18 at 19:41
  • 1
    @GBG There is no "on the fly" checkbox in the project properties box. To my knowledge, on-the-fly is enabled by default in QGIS 3.x and cannot easily be disabled. – Stephen Bosch Nov 22 '18 at 8:05
  • 1
    It is no matter of QGIS 3.x. On QGIS 2.x you see the same offset, regardless of the chosen project CRS. – AndreJ Nov 22 '18 at 10:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.