2

I have an Israeli database with X and Y values that I need to upload into QGIS.

I have converted the Excel file into a CSV UTF-8 (Comma delimited) file and upload it as Delimited Text Layer.

I have tried all the Israeli CRS listed in QGIS, and that data is still not matching.

enter image description here

It sure do look like the Israel outlines, but it is about 700kM off somewhere in the Egyptian desert. enter image description here

What is needed in order to fix this problem?

3

Your problem is related with the incompatibility of the decimal separator of your software, your system and maybe your data also. It is a quite common challenge, see PEP-378 and it deserve a lot of care to deal with it properly, specially if you are reading data from other

The decimal separator comes togheter with the list separator, thousands separator and other "cultural issues". I would say that in Qgis the dot as decimal separator is the best option becuase Python (and C) uses it internally and not all tools handle the local configuration in a good way.

Incompatible decimal separators is a pain we must learn to live with.

| improve this answer | |
2

I seem that I have figured it up, and the problem is quite an odd one.

The X and Y values are listed with a dot between the third and fifth numbers. In QGIS the CRS values are written without a dot, so obviously it cannot work like that.

enter image description here

Once I multiplied the numbers by 1,000 and uploaded the values as a whole number it fits the Israeli CRS.

enter image description here

| improve this answer | |
  • It should be possible to eliminate the thousands separator dot inside Excel cell/number formatting before exporting. Or you can use a simple text editor like notepad++ to exchange all dots inside the csv to nothing. – AndreJ Nov 22 '18 at 15:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.