2

So, the situation involves :

  • QGIS 2.18 and georerencer plugin;
  • Downloaded TIF of an old canadian topographical map from Quebec National Library and Archives (permalink here) and as you can see, this nice map included a grid with latitude and longitude.
  • The project I'm working on includes vector data using NAD83 MTM7.

Now, the problem :

  • Right after selecting file in the georeferencer plugin, I have to enter what i think is the CRS of the original map, which I don't have a lot of info on (It says "polyconic projection" only).
  • I was under the impression that "real" lat/long would be more than enough to georeference it precisely, but it appears that a entering a CRS is essential!

EDIT : Here's a screen capture of the menu prompted when adding the raster. It's in french, but in the first field, it translates to "select the CSR for the raster layer" enter image description here

Now, the questions are :

  1. Is there any way I can avoid specifying a CRS when using georeferencer and just enter the lat long of the grid corner? Something that would tell QGIS "Look, forget the CRS, I have latitude and longitude and that all you need!"
  2. If answer to question 1 is "No", what should I do?
  • 2
    Where in the georeferencer does it force the specification of a CRS of the original map? The area is small enough that you can first try a linear transformation to whatever target CRS you want, and with just the four corner points I get a pretty accurate match to an underlying OpenStreetMap, even though these can't be WGS84 lat-long coordinates on the map. Perhaps if you set the CRS to the lat-long coordinate system (not the projection) then the lat-longs entered for the corner will be in that system... – Spacedman Nov 23 '18 at 17:36
  • 2
    Also if you enter many control points in the georeferencer, eg at many of the lat-long intersections, then you can use one of the other transform types to go beyond a linear transformation into more of a stretch/warp kind of transform. But the grid lines are so straight and parallel on your image that this seems overkill. – Spacedman Nov 23 '18 at 17:38
  • Hmmmm. 3.4 on this laptop asks for a CRS but the one on my desktop which is slightly newer doesn't.... Its not clear what DMS CRS the georeferences accepts in its coordinates box is it? – Spacedman Nov 23 '18 at 21:05
  • I guess the asking comes from the QGIS setting for the CRS of new layers. But it is not used in the georeferencer. The georeferencer does not accept any DMS input, only decimal degrees, meters or feet. You can set the target CRS in the settings, and the coordinates are interpreted in that CRS. If you fetch the coordinates from the QGIS canvas by mouseclick, target CRS and project CRS should be the same. – AndreJ Nov 24 '18 at 10:00
  • Edited the post to add a picture of the windows asking to select a CSR when opening the raster through the georeferencer, and format the post and the questions. – LBLIB Nov 26 '18 at 15:10
0

If you load a new raster (at least in QGIS 2.18), you may get prompted for a CRS. I never understood why. It might be a global setting for adding new layers, but it has no effect at this stage.

In the settings of the georeferencer (the yellow gear-wheel icon), you have to specify the target CRS, and an output filename. If you want to enter degrees, I suggest to take NAD27, not WGS84 or NAD83. Keep in mind it is an old map!

You can not run the Georeferencer without specifying any CRS, because the output Geotif needs one. Remember that latlon degree CRS are also valid CRS!

In fact, you have a whole bunch of geographical CRS, all using latlon degrees, but on different ellipsoids, and some with a center meridian different from Greenwich.

Since the map is older than NAD27, you can not be sure what datum is actually used. So you might be better off by georeferencing against recognizable points (like street or railway crossings) compared to a current basemap like Openstreetmap or Google imagery via the QMS plugin. In that case, I suggest to set project and georeferencer CRS to EPSG:3857.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.