0

I'm attempting to upgrade GeoServer 2.9.2 to 2.13.3. GeoServer uses the Oracle Data Store plugin (updated to gt-jdbc-oracle-19.3 as part of the upgrade). Oracle is 11gR2.

One of the applications using GeoServer creates and deletes features in an Oracle-based layer over WFS-T (version 1.0.0). With 2.9.2 it can successfully create and delete. However with 2.13.3 it can still create but cannot delete.

GeoServer logs the following error:

Caused by: java.io.IOException: Error occured calculating bounds for LAYER_NAME
at org.geotools.jdbc.JDBCDataStore.getBounds(JDBCDataStore.java:1345)
at org.geotools.jdbc.JDBCFeatureSource.getBoundsInternal(JDBCFeatureSource.java:513)
... 118 more
Caused by: java.sql.SQLSyntaxErrorException: ORA-00933: SQL command not properly ended

Getting the exact SQL from Oracle requires me to jump through a few hoops within our organisation, so I don't expect to have that information until next week some time. Is this a known issue? Are there compatibility issues between this version of GeoServer and Oracle 11gR2?

  • If you turn up logging in GeoServer to debug you will see the exact query written in the log file. None of the devs work with Oracle on a volunteer basis so there may be issues with the driver. – Ian Turton Nov 24 '18 at 8:34
2

Likely due to https://osgeo-org.atlassian.net/browse/GEOT-6178, which has been fixed in the meantime. Next 2.13.x release is late December 2018, in the meantime you can try downgrading to an earlier 2.13.x version and see if that fixes your issue.

  • many thanks - 2.13.2 does not exhibit this problem – tomfumb Nov 26 '18 at 18:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.