I'm trying to select by attributes on a parcel shapefile with 555k+ records using the apn field and the statement is returning records that have completely different values. My initial statement was "apn" = '525-670-10-2'

And received the top two records with APNs starting with 84A.

Then I tried a wild card and got a whole slew of records starting with 84A:

enter image description here

Has anyone encountered this and was able to correct it? I'm using ArcMap 10.6

  • 1
    try copying an apn cell and paste it to notepad. Does it match? Also this may be pointless but have you tried "apn" like '525%670%'? Does it always return the 84A-...? If you do a ctrl+f and search the apn column for 525-670-10-2, do you get a match? – jbalk Nov 29 '18 at 22:57
  • 1
    also what is the datatype of the apn column? – jbalk Nov 29 '18 at 22:58
  • 3
    Maybe rename your Shapefile to something simple and short, it is a bit long with dashes and underscores. – klewis Nov 29 '18 at 23:48
  • I second klewis. Naming shapefile like this is bad idea. – FelixIP Nov 30 '18 at 20:01
  • You could try generating a shapefile with 555K+ records - half with this problematic value and half with another then see if that gives the right result. If not, do the same in a file geodatabase feature class and try again. – PolyGeo Jan 28 '20 at 10:27