3

Whenever I run any processing algorithm in QGIS, after it finishes I get Windows 10 pop-ups (notofications in lower-right corner) which says that the processing is finished. It is very annoying, particularly when I run very quick and simple algorithms, because it makes QGIS window out of focus and to get back to work I have to close the pop-up first.

How can I disable Windows 10 notifications for QGIS?

  • 1
    Upgrade to QGIS 3.4 -- they only show for long running tasks on 3.4 – ndawson Dec 2 '18 at 20:10
  • Which QGIS version are you using? The behavior has changed in 3.4. – etrimaille Dec 3 '18 at 12:12
  • This is QGIS 3.2. I use this version because 3.4 causes some problems with Python while using GRASS algorithms – Karol Daniluk Dec 3 '18 at 20:33
  • Aaaaah! then my answer did not capture the real cause of this issue, sorry. Will you guys post it as answer? – Kazuhito Dec 10 '18 at 12:13
8
  1. Open the Windows Settings menu by pressing the Windows Key and “I”
  2. Click on "System" (Display, notifications, apps, power)
  3. Click “Notifications & Actions” menu
  4. Wait a few seconds until Windows finds and lists all apps which uses "Notifications"
  5. Scroll down list of apps and find QGIS
  6. Turn it off
  7. Enjoy!
  • The problem is there is no QGIS on this list. The pop-up looks like this: imgur.com/CUAZYSh – Karol Daniluk Dec 2 '18 at 14:28
  • @KaRolthas Could you translate it for me to understand what it is? – Kazuhito Dec 3 '18 at 9:20
  • "Zadanie ukończone" is "Task is finished" and "Punkty wzdłuż geometrii" is the name of algorithm "Points along geometry" – Karol Daniluk Dec 3 '18 at 20:36
  • Thanks @KaRolthas Unfortunately I cannot reproduce it by my quick tests. – Kazuhito Dec 4 '18 at 0:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.