0

I have a shapefile from a county HER which I have successfully loaded. I have catagorised the point so depending on type they show a different symbol. I can filter those points in order to show them by period etc. However, the toggle editing option is not there and I need this to manual move and place labels.

So I save the file as ESRI shapefile. Categorise and the toggle editing is now showing for me to manual move labels. However, the ability to filter is not there it is greyed out.

Is there any way around this?

  • What filter are you talking about? The one in attribute table, or the feature filter within layer settings, or something else? Can you provide a screenshot? – MrXsquared Dec 2 '18 at 20:08
1

When a layer is filtered using the Feature Filter, it cannot be edited. Likewise, a Feature Filter cannot be applied to a layer in edit mode. If you hover your mouse over the grayed-out Query Builder button while in editing mode, you will see a mouseover text that reads "Stop editing mode to enable this."


If you need the ability to edit your layer, try a different method of filtering, such as rule-based style:

Convert your categorized style to rule-based style. enter image description here

Add a new rule, add the desired filter expression to it, and turn off symbology. In the example below, I have the layer filtered to features with the "year" value greater than 1995. enter image description here

Nest the category rules under the new rule.

enter image description here

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.