2

I've derived a raster of slopes from a 10 m DEM resampled to 15 m for an area of approximately 20,000 mi^2. I want to use Python to reclassify those slopes into categories according to range, but whenever I run the code (and I have tried on 3 different machines) I get the following error:

"ExecuteError: ERROR 010005: Unable to allocate memory. Failed to execute (Reclassify)."

My understanding based on this description (http://pro.arcgis.com/en/pro-app/tool-reference/tool-errors-and-warnings/010001-020000/tool-errors-and-warnings-10001-10025-010005.htm) is that the machine I'm working on does not have enough system memory. However, considering that the area is not very large and I have tried it on multiple machines, this doesn't make sense to me. Working on a 16 GB machine with 15.9 GB available. Am I missing something/does anyone have suggestions for why my code is not working? The code is listed below

import os
import sys
import arcpy

arcpy.env.workspace = "D:\\SanDiskSecureAccess\\ProgrammingProject\\mudslideanalysisdata.gdb"

slope = "Slope_DEM_ma1"

arcpy.env.mask = "DEM_mask"
arcpy.env.cellSize = 15

slopeRemapRange= RemapRange([[0, 4.5, 1], [4.5, 9, 2], [9, 15, 3], [15, 25, 4], [25, 35, 5], [35, 80.816727, 6]])
outReclassSlope = Reclassify(slope, "VALUE", slopeRemapRange)
outReclassSlope.save("SlopeReclass")
  • 1
    Several things to note: you say you are using a 10m resolution DEM yet you have set cell size to 15. As you have set the workspace this is saying that both your slope AND mask rasters are in mudslideanalysisdata.gdb, is that correct? All the code examples in the Help file show the value field as "VALUE", yours is in mixed case. – Hornbydd Dec 2 '18 at 16:34
  • 1
    If the software states that there is insufficient memory, the question really ought to state how much RAM and swap has been configured and used on the system. – Vince Dec 2 '18 at 17:55
  • 1
    Two things I would do is first: is just try reclassifying without resampling cell size, secondly use the reclassify tool rather than in python, if that works you could always "copy snippet" from the results to see what the difference is in syntax (if any). – Hornbydd Dec 2 '18 at 18:23
  • 1
    Please Edit the question in response to requests for clarification. It's not fair to those who would help you to need to sift through comments for information. It seems unlikely that a running Windows machine with Pro active would have no RAM used whatsoever, so it's probably worth the effort to determine RAM utilization at the point just before your attempted operation. – Vince Dec 2 '18 at 19:03
  • 1
    This could be more to do with your %TEMP%/%TMP% (environment variables in Windows) than your system memory, is your %userprofile% under quota managment? do you have lots of free space on your C drive? Can you move your temp to another drive that has more space? Many of the spatial analyst tools convert your input raster into a GRID in one of your %TEMP% or %TMP% folder, apply the tool to another GRID then convert the GRID to your output format before removing the temporary GRIDs... if there isn't sufficient space on your system drive you can get this error message. – Michael Stimson Dec 3 '18 at 0:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.