When I try to run PostGIS 2.0 Shapefile and DBF Loader Exporter I get the following error:

The program can't start because libintl-9.dll is missing from your computer. Try reinstalling the program to fix this problem.

I this previous question which asked a similar question about libintl-8. Following Devdatta Tengshe's answer I checked "C:\Program Files\PostgreSQL\11\bin" and the file is there:

enter image description here

then I checked pgadmin4's binary filepath and it's pointed at the same directory:

enter image description here

Where do i got from here?

  • @JGH - Thanks, I'll try putting it in that folder once I get an admin on the line. – TeddyTedTed Dec 3 '18 at 12:57
  • copying the libintl-9.dll in C:\Program Files\PostgreSQL\11\bin and pasting in C:\Program Files\PostgreSQL\11\bin\postgisgui has worked! thanks – Oytisa Onato Nov 17 '20 at 12:45

It might be required in C:\Program Files\PostgreSQL\10\bin\postgisgui (or wherever the loader is installed).

It is however suspicious that the lib isn't included in the installer, and it might reveal other issues

  • This works, once that's in it also asks for libwinpthread-1.dll which just needs to be moved in as well. Thanks. – TeddyTedTed Dec 3 '18 at 15:57
  • I had the exact same issue today and moving those two files fixed it... though now I'm wary moving forward and hope this won't cause any issues down the road. – mikeLdub Dec 4 '18 at 14:55
  • @mikeLdub - If the shapefile uploader doesn't work then you can use QGIS to load data into Postgres. Not ideal I know but still. – TeddyTedTed Dec 4 '18 at 14:58
  • Copying the file into subfolder postgisgui did the trick – Kurt Oct 25 '20 at 20:44

Go to C:\Program Files\PostgreSQL\10\bin\postgisgui (or wherever the loader is installed). For example, for me, C:\Program Files\PostgreSQL\11\bin\postgisgui.

Make a copy of the libintl-8.dll and paste it in the same directory. Rename it, libintl-9.dll (with the number 9) instead of libintl-8 - Copie.dll

Now, re-run PostGIS 2.0 Shapefile and DBF Loader Exporter (as Administrator).

You will have access to the PostGIS Shapefile Import/Export Manager.

  • Excellent - worked a treat. – IanGS Jun 22 '19 at 16:46

I found the libintl-9.dll file in the folder :

C:\Program Files\PostgreSQL\11\bin\

and copied it to the folder :

C:\Program Files\PostgreSQL\11\bin\postgisgui

then ran the .exe file in that folder and it worked.


That worked for me (postgresql-11.3-1-windows-x64) :

  1. check that there is a libintl-9.dll in C:\Program Files\PostgreSQL\11\bin directory
  2. add that directory to PATH environment variable (original answer from https://tutel.me/c/gis/questions/229819/how+to+solve+missing+libintl8dll+error+with+postgis)
  • instead of adding the libint-9.dll to environment variable, instead you can place it inside C:\Program Files\PostgreSQL\11\bin\postgisgui and it'll work. – muzaffar Jun 17 '19 at 9:25

Juste upgrade your PostgreSQL and your PostGIS to the last version

I got the same problem with postgreSQL 11.2 and postgis 2.5.2. Apparently this problem has been solved since then. I now run with postgreSQL 11.5 and postgis 2.5.3 and everything is fine

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.