0

I have a problem.

  1. I used the mosaic to raster tool to form one large raster of the study area.
  2. Using the clip tool, I clipped the boundary of the study area to this large raster map.

BUT! There is now a black rectangular box outside the study area boundary that I cannot remove.

This black area is showing as 'nodata', so I cannot remove it using the symbology function.

enter image description here

How can I remove the black background using ArcGIS Desktop?

1
  • Another approach is to use the tool called Extract by mask to deal with the NA values (black box outside of your study area.
    – Nikos
    Sep 10, 2023 at 18:07

2 Answers 2

3

In ArcGIS, if your output is a GRID then use the layers Symbology to not display the NoData values as shown below. enter image description here

If your output is a single band image you can set Display Background Value as 0,0,0 and as No Color but any pure back pixels will not be displayed not just the ones on the border. enter image description here

0

I was also facing similar issues. The no data option in the symbology didn't work for me. However, I conducted the clip/extract operation and tried to save the output raster within a geodatabase instead of a general folder, it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.