2

I'm trying to use gdal_proximity to create a distance raster. When I try to run it independently, it works fine. However, when I try to use it within modeler, it encounters an error. I've attached two images of the dialogue boxes for the Gdal_Proximity, the first one is the dialogue when using it inside the modeler. The only difference I see is the Band number part.

Dialogue within modeler

Dialogue when running independently

This is the error message I get when running in the modeler:

Prepare algorithm: gdal:proximity_1 Running Rast_proximity [6/6] Input Parameters: { BAND: 1, DATA_TYPE: 5, INPUT: '', MAX_DISTANCE: 0, NODATA: 0, OPTIONS: '', OUTPUT: >'C:/Users/Reymar.Victoria/AppData/Local/Temp/processing_7b1696077f6c49b0aa61746e14dc2547/6e2edaf05ea14791966e7f34ab933e2b/gdal_proximity_1_out_rast3_proximity.tif', REPLACE: 0, UNITS: 0, VALUES: '100' } Traceback (most recent call last): File "C:/OSGEO4~1/apps/qgis/./python/plugins\processing\algs\gdal\GdalAlgorithm.py", line 126, in processAlgorithm commands = self.getConsoleCommands(parameters, context, feedback, executing=True) File "C:/OSGEO4~1/apps/qgis/./python/plugins\processing\algs\gdal\proximity.py", line 141, in getConsoleCommands raise QgsProcessingException(self.invalidRasterError(parameters, self.INPUT)) _core.QgsProcessingException: Could not load source layer for INPUT: invalid value

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.