0

I am using gdal_translate -b ... in.sid out.sid to remove excess bands (there are 5 bands) from .sid files as a layer created from these .sid's will be a JPEG layer. When executing command on a .sid file and expecting to get .sid file as an ouput but I get a .tiff and a warning

Warning: The target file has a 'sid' extension, which is normally used by the MrSID driver,
but the requested output driver is GTiff

"The following format drivers are configured and support output" list does not show MrSID driver among supported drivers.

How to make gdal_translate support MrSID driver?

  • MrSID en.wikipedia.org/wiki/MrSID is licensed, by LizardTech last time I looked, but links go to extensis extensis.com, you could purchase a license to compress but from experience that still wont help GDAL_Translate - you have to use their compressor utility. – Michael Stimson Dec 5 '18 at 6:13
2

As documented in https://www.gdal.org/formats_list.html ("no" in both Creation and Copy columns) and in https://www.gdal.org/frmt_mrsid.html the driver is read-only.

This driver supports reading of MrSID image files using Extensis' decoding software development kit (DSDK).

Use some of the drivers which support writing. GeoTIFF is not a bad choise. It is also a good practise to define the desired output driver explicitly with -of parameter even GDAL makes some guessing by the filename extension.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.