2

I have added 6 ArcGIS Online layers to an ArcMap 10.3.1 project (.mxd). When I attempt to add additional online layers: "File --> Add Data --> Add Data from ArcGIS Online" ArcMap hangs for a second, releases, and no layer is added to the Table of Contents.

I have attempted clearing the Display Cache, as well as signing out of my AGOL Account. I am using an AGOL account affiliated with a University that does not have any credit limits. I have conducted a search and not been able to find any documentation from ESRI relating to maximum number of AGOL layers in an ArcMap project.

Has anyone else encountered this behavior, or detected a maximum number of AGOL layers?

1
  • @Jon and NULL.Dude you are both on to something. My data frame was set to a local coordinate system, as the first layer I added to my project was a county boundary. AGOL layers are initially capable of projecting on the fly, but as the number of layers increases, I begin to experience a decrease in performance. USA Historical Topo Maps 1:250,000 scale would not draw. Changing the data frame to EPSG 3857 WGS_1984_Web_Mercator_Auxiliary_Sphere gets it to draw.
    – M. Graham
    Dec 7, 2018 at 20:04

1 Answer 1

2

Based on the comments, it appears that your problem is that your map dataframe is set to a different CRS than the online maps (which are all apparently EPSG 3867). Because of this, ArcGIS Online is trying to reproject the Online Layers on the fly, which is a huge draw on system resources.

You can fix this by simply changing your dataframe to display the same CRS as the Online Layers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.