1

I'm trying to run r.neighbors in QGIS 3.4.1-Madeira and can't find the log that comes up with what looks like a red error message. I've also tried a couple of other GRASS processing tools and they don't work so suspect it's a path/permissions problem of some kind. This is on a Mac, High Sierra.

Trying to see the errors ... nothing in the logs via View - Panels - Log Messages. Also under processing the box is checked to keep the dialog open after running an algorithm, but it still comes up then goes away before you can see what it says.

  • Via some quick screen captures I was able to see the error and it looks like it's fairly well known, "env: python3: No such file or directory" per: issues.qgis.org/issues/18704. Via gis.stackexchange.com/questions/304245/… it can be partially solved, but seems ultimately that GRASS 7.4 does not work with QGIS 3.x so will use QGIS 2.x in the short-term. – cokrzys Dec 10 '18 at 14:35
  • GRASS GIS 7.7+ is supporting Python3. – markusN Dec 14 '18 at 21:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.