0

I'm trying to make a cql filtered wms request for a non image based format like geojson or mapbox vector but the filters aren't applying. If i change the format to image/png the filters behave as expected.

Is this functionality not supported by geoserver? We're running version 2.11.

Working request (filtered)

{{host}}/ows?bbox=16115371.547420282,-4546474.442402283,16115983.043646563,-4545862.946176002&format=image/png&service=WMS&version=1.1.1&request=GetMap&srs=EPSG:3857&transparent=true&width=512&height=512&layers=LINE_NB&CQL_FILTER=SEASON_KEY='BASE_2018_SUMMER'

Failing request (not filtered)

{{host}}/ows?bbox=16115371.547420282,-4546474.442402283,16115983.043646563,-4545862.946176002&format=application/x-protobuf;type=mapbox-vector&service=WMS&version=1.1.1&request=GetMap&srs=EPSG:3857&transparent=true&width=512&height=512&layers=LINE_NB&CQL_FILTER=SEASON_KEY='BASE_2018_SUMMER'

URL encoding the query string makes no difference to the result.

  • please add which version of GeoServer you are using and example requests that work and fail using the default layers. – Ian Turton Dec 7 '18 at 9:54
1

Well, it looks like this issue has been fixed in a later release. Updating to 2.14 solved this for me. I also did the protobuf 3.6.1 update, not sure if that made a difference at all but the CQL Filters now work.

As a side note, this update also brought with it compatibility for the V2 vector tile spec which is nice, no more Mapbox deprecation warnings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.