I've opened a .shp in QGIS 3.2.3 and there is no data in the attribute table. It shows the correct number of rows but no columns.

A previous answer recommended choosing "Show All Objects" under the "General" tab in Options, but that option does not exist in QGIS 3.2.3.

Would anyone be able to provide advice on this?

(I also tried installing QGIS 3.4 to see if that resolved the issue and that didn't work either)

EDIT: The previous answer I refer to is this one.

  • You can check if there actually is data by opening the *.dbf file with LibreOffice Calc. Once had the same issue and removing and re-adding the shapefile from my project solved this issue.
    – MrXsquared
    Dec 8, 2018 at 17:33
  • There is data in the *.dbf file, and QGIS actually shows a map. It's just the attribute table is empty.
    – JemJem
    Dec 8, 2018 at 18:10
  • You mention prior/previous answers but what question(s) do those come from? Whenever you refer to previous questions or answers from this site it is helpful to include links to them so that potential answerers do not have to waste time trying to figure out what you have already looked at.
    – PolyGeo
    Dec 8, 2018 at 20:29

1 Answer 1


It shows the correct number of rows but no columns.

It seems that the columns are hidden.
Add a new column, right click on the name of the column and click on Organize Columns...
Ticking their names, they should be shown again.

Organize Columns...

  • Unfortunately I can't even create a new field. The option to do so is greyed out. EDIT: if I create one using the field calculator and go to Organize Columns, no columns are listed.
    – JemJem
    Dec 10, 2018 at 16:50
  • Toggle editing mode (Ctrl+E) to create a new column or delete an existing. Is it possible that the table has no attributes. Once the column is created, click on *Organice columns...", if there are no columns there, it is likely that entities do not have attributes attached. Dec 10, 2018 at 17:45
  • Ah, nothing showed up, so it's not there! I have a .dbf file with the shapefile's information in it, though. Is there a way to import it into the attribute table? Or should this be a new question?
    – JemJem
    Dec 10, 2018 at 18:27
  • 1
    Do you have the .dbf file at the same folder and with the same name that the .shp file? If so, just add a new vector layer with that .shp file. Dec 10, 2018 at 18:41
  • They didn't have the same name! That was it, thank you so much!
    – JemJem
    Dec 10, 2018 at 18:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.