1

I want to install QGIS 3.4 above and did exactly the same as this page: QGIS Installers

and tried the codes below having no error at all:

(1) add the following lines to /etc/apt/sources.list

deb https://qgis.org/ubuntu xenial main

deb-src https://qgis.org/ubuntu xenial main

(2) wget -O - https://qgis.org/downloads/qgis-2017.gpg.key | gpg --import

gpg --fingerprint CAEB3DC3BDF7FB45 which gives the results below:

pub 2048R/BDF7FB45 2017-08-16 [expires: 2019-08-16] Key fingerprint = 61E0 A086 749E 463E DE50 2255 CAEB 3DC3 BDF7 FB45 uid QGIS Archive Automatic Signing Key (2017) sub 2048R/E959BBCF 2017-08-16 [expires: 2019-08-16]

then:

gpg --export --armor CAEB3DC3BDF7FB45 | sudo apt-key add -

at last:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-key CAEB3DC3BDF7FB45

(3) sudo apt-get update

(4) sudo apt-get install qgis python-qgis qgis-plugin-grass

every thing goes fine except that these codes installs only QGIS 2.18 but not 3.4 above?

I have tried other repositories as well and it still goes the same and installs QGIS 2.18

I need a solution and I need this software on my Ubuntu.

Regards.

4

If you follow the instructions from the QGIS Installers page, you will see the following information under the "Supported distribution versions:" table:

Ubuntu 16.04 (LTS) xenial [5]
...

[5] 3.0 and above only available with ubuntugis-unstable (plain xenial lacks GDAL2)

enter image description here

So, add the ubuntugis-unstable ppa:

sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable

Then use the "Release with ubuntugis-unstable dependencies" repository (https://qgis.org/ubuntugis) in your /etc/apt/sources.list

deb https://qgis.org/ubuntugis xenial main
deb-src https://qgis.org/ubuntugis xenial main

You should then be able to install QGIS 3.4.2 according to the packages list:

Package: qgis
Version: 1:3.4.2+24xenial-ubuntugis
Architecture: amd64
Maintainer: QGIS developers <qgis-developer@lists.osgeo.org>
Installed-Size: 9720
Depends: gdal-abi-2-2-2, libc6 (>= 2.14), libgcc1 (>= 1:3.0), libgdal20 (>= 1.8.0), libgeos-c1v5 (>= 3.4.2), libgsl2, libqgis-analysis3.4.2, libqgis-app3.4.2, libqgis-core3.4.2, libqgis-gui3.4.2, libqt5core5a (>= 5.5.0), libqt5gui5 (>= 5.0.2) | libqt5gui5-gles (>= 5.0.2), libqt5keychain0 (>= 0.3.0), libqt5network5 (>= 5.0.2), libqt5sql5 (>= 5.0.2), libqt5widgets5 (>= 5.2.0), libqt5xml5 (>= 5.0.2), libstdc++6 (>= 5.2), ocl-icd-libopencl1 | libopencl1, ocl-icd-libopencl1 (>= 1.0) | libopencl-1.1-1, python-qgis (= 1:3.4.2+24xenial-ubuntugis), qgis-providers (= 1:3.4.2+24xenial-ubuntugis), qgis-common (= 1:3.4.2+24xenial-ubuntugis)
Recommends: qgis-plugin-grass
Suggests: gpsbabel
Conflicts: uim-qt3
Homepage: http://qgis.org/
Priority: optional
Section: science
Filename: pool/main/q/qgis/qgis_3.4.2+24xenial-ubuntugis_amd64.deb
Size: 6675744
SHA256: ac91806eb635de040e33b8178b340a2d0a604be9f0efad804b06b024a27c1f1e
SHA1: 1d08b3f07c7323f937a0fc4c0eb53327a655de4e
MD5sum: 3a584cde9314eace49e651a197197a2f
Description: Geographic Information System (GIS)
 A Geographic Information System (GIS) manages, analyzes, and displays
 databases of geographic information. QGIS supports shape file viewing and
 editing, spatial data storage with PostgreSQL/PostGIS, projection on-the-fly,
 map composition, and a number of other features via a plugin interface. QGIS
 also supports display of various georeferenced raster and Digital Elevation
 Model (DEM) formats including GeoTIFF, Arc/Info ASCII Grid, and USGS ASCII
 DEM.
  • It might be necessary to add the ubuntugis key as well. Before installing, use sudo apt-cache policy qgis to see what is available for you. – AndreJ Dec 9 '18 at 4:57
  • @AndreJ possible, but unlikely as add-apt-repository by default adds the key. – user2856 Dec 9 '18 at 5:45
  • @Luke It worked perfectly. thank you for your great details. Regards – Nima Dolatabadi Dec 10 '18 at 13:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.