5

I want to add a repository to my QGIS 3.4 which is on a private server. The repository contains all files needed (plugin.xml and metadata.txt for example) and has the structure as described here:

Is it possible to set up a local QGIS Plugin repository?

To access the repository, a p12 certificate is needed which I am able to load into qgis. The issue is that in order to access the plugins.xml file and zip of the plugin on the private repository, we need to also enter a username and password, which I cannot specify in qgis.

I tried with putting the plugins.xml on a network drive, and am able to see that the status of the repository is set to "enabled". But when I try to download the plugin, I get the error:

Plugin installation failed: Failed to unzip the plugin package. Probably it's broken or missing from the repository. You may also want to make sure that you have write permission to the plugin directory: C:/...\profiles\default/python/plugins

I am sure that I have permission to the directory, any idea how I can specify the user name and password in qgis in addition to the certificate as authentication method, so it can download the plugin zip file?

  • The parameter "?qgis=3.4" is added, so repositories can filter the results shown, so 2.x plugins don't show up in QGIS 3.4. Usually this is a good thing. Most servers just ignore those extra parameters if they don't recognize them, but maybe your server can't handle it. – Michel Stuyts Dec 13 '18 at 13:58
  • ok thanks for the explaination! I think thats actually not the problem because I have tested and the server can handle that parameter. – Ending Dec 13 '18 at 14:44
  • AFAIK the networkaccessmanage manage redirection, that seems your case and I remember ths sistem authentication for plugin repo worked correctly at least untile 2.18. Can you check if you can connect to plugin repo with other qgis versions? .e.g 2.18 and 3.2? – Luigi Pirelli Jan 22 at 18:14
  • @LuigiPirelli I tried it in 2.18 and the behaviour is unfortunately the same. – Ending Jan 23 at 7:22
  • What is the username and password for? Is it network credentials just to view the files on the network or is it something else? If you try to browse to the repo through file explorer does it prompt you for a user name and password? If so, you may need to put in your credentials there when accessing it through the file explorer and check the box to save your credentials. I've had similar issues with getting Visual Studio to access a local Nuget repo. – TJ Rockefeller Jan 24 at 21:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.