4

I have some road network data from OSM in EPSG:4326, a polygon representing the boundary of some city in EPSG:4326 that is out of date, and an up to date version of that polygon that is not in EPSG:4326. When I check the properties, it says the CRS is the following:

Generated CRS (+proj=lcc +lat_1=44.33333333333334 +lat_2=46 +lat_0=43.66666666666666 +lon_0=-120.5 +x_0=2500000 +y_0=0 +ellps=GRS80 +towgs84=0,0,0,0,0,0,0 +units=ft +no_defs)

Now what I want to do is to filter the roads for only those within the city limits then create nodes at the endpoints of the streets. I am using QGIS 2.18.26.

Using the out of date boundary data in EPSG:4326, I can use the Intersection tool to get the streets in the city limits, then use the v.to.points tool in the Processing toolbox to get the endpoints of the streets:

old-city-limits-nodes-success

Using the new city boundary data, I changed the projection to EPSG:4326 using Save As... Then used the Intersection tool in the same way, which worked fine. But then when I use the v.to.points tool, there is no output:

new-city-limits-nodes-failure

I assume this has something to do with how I changed the projection, but I'm very new to this stuff so I'm not sure where to go next.

UPDATE

I was asked to paste the output of the Log tab for the v.to.points tool. The process just runs and then closes so I can't really look at the output. According to this documentation, I should be able to see the log output at Processing -> History, but there is no log info there, just the "Algorithm" directory that logs the function call.

That being said, I tried going to the Log tab and copying the text in there while the process was running. So I may not have all the output, but I see some error messages, so hopefully it is enough for someone else to see what is going wrong:

Algorithm v.to.points - Create points along input lines starting...
g.proj -c proj4="+proj=longlat +datum=WGS84 +no_defs"
v.in.ogr min_area=0.0001 snap=-1 input="/tmp/processing675fd71b428d47058b057854bf85d1c7" layer=1544809798.2236 output=tmp15448097982637 --overwrite -o
g.region n=45.3300102346 s=45.2834281428 e=-122.925625688 w=-122.98844688 res=100
v.to.points input="tmp15448097982637" dmax="100" use=node output="output5d61527a7ac04a79884d43ae47610b99" --overwrite
v.out.ogr -s -e input=output5d61527a7ac04a79884d43ae47610b99 type=auto output="/tmp/processing675fd71b428d47058b057854bf85d1c7/08803dbec4b44cc99b453612ce41e56f" format=ESRI_Shapefile output_layer=output --overwrite
Starting GRASS GIS... 
Executing '/home/mikey/.qgis2//processing/grass7_batch_job.sh' ... 
Default region was updated to the new projection, but if you have multiple mapsets `g.region -d` should be run in each to update the region from the default 
Projection information updated 
Over-riding projection check 
Check if OGR layer contains polygons... 0..2..4..6..8..10..12..14..16..18..20..22..24..26..28..30..32..34..36..38..40..42..44..46..48..50..52..54..56..58..60..62..64..66..68..70..72..74..76..78..80..82..84..86..88..90..92..94..96..98..100
Importing 1459 features (OGR layer )... 0..2..4..6..8..10..12..14..16..18..20..22..24..26..28..30..32..34..36..38..40..42..44..46..48..50..52..54..56..58..60..62..64..66..68..70..72..74..76..78..80..82..84..86..88..90..92..94..96..98..100
Building topology for vector map ... 
Registering primitives... 

1471 primitives registered 
5379 vertices registered 
Building areas... 0..2..4..6..8..10..12..14..16..18..20..22..24..26..28..30..32..34..36..38..40..42..44..46..48..50..52..54..56..58..60..62..64..66..68..70..72..74..76..78..80..82..84..86..88..90..92..94..96..98..100 
0 areas built 
0 isles built 
Attaching islands... 
Attaching centroids... 1..3..5..7..9..11..13..15..17..19..21..23..25..27..29..31..33..35..37..39..41..43..45..47..49..51..53..55..57..59..61..63..65..67..69..71..73..75..77..79..81..83..85..87..89..91..93..95..97..99..100 
Number of nodes: 1150 
Number of primitives: 1471 
Number of points: 0 
Number of lines: 1471 
Number of boundaries: 0 
Number of centroids: 0 
Number of areas: 0 
Number of isles: 0 
DBMI-SQLite driver error: 
Unable to scan date: 

DBMI-SQLite driver error: 
Unable to scan date: 

WARNING: Unable to fetch data from table 
ERROR: Unable to copy table 
WARNING: Table linked to vector map does not exist 
ERROR: Vector map not found 
Execution of '/home/mikey/.qgis2//processing/grass7_batch_job.sh' finished. 
Cleaning up temporary files... 
Starting GRASS GIS... 
Executing '/home/mikey/.qgis2//processing/grass7_batch_job.sh' ... 
ERROR: Vector map not found 
  • Hi @Mikey. Can you copy the output from the Log tab of the v.to.points tool in the question? – Gabriel De Luca Dec 14 '18 at 3:13
  • @GabrielDeLuca I've added some of the log output. – Mikey Dec 14 '18 at 18:03
3

Okay found a solution! It looks like someone had a similar problem in this ticket. They had some Date attribute that had some problems (hence the "Unable to scan date" error I had). I didn't actually need those date column(s) that were just filled with Nulls anyway, so I just removed those attributes, and things seem to be working smoothly! :)

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.