1

In QGIS 2.18, shapefiles are not editable when loaded in the timeManager. Is there a workaround?

Or do you know if this is available in more recent version?

The timestamps in the shapefile are set in seconds which by default refer to the seconds elapsed since 1/1/1970.

  • Are you mapping in geologic time? Shapefile s only support day resolution (no HHMMSS) – Vince Dec 14 '18 at 14:19
  • the time in the shapefile is set in seconds since a reference time which is by default 1/1/1970. the display works fine. my issue is that I cannot enable the edition tool when the shapefile is loaded in the timemanager. – paugam Dec 14 '18 at 14:58
  • Please put this information in the body of the question. The fact that you're using an integer field is probably relevant to the issue. – Vince Dec 14 '18 at 16:19
1

The TimeManager plugin controls the editing of its layers when it's on.

So, just turn it off while you are not playing the sequence and that layers will be editable again.

UPDATE: In QGIS 3.4.2 the plugin doesn't block shapefile layers.

  • when I turn off the timemanger then all feature show up and finding the one that matches the time where i stop is not easy – paugam Dec 14 '18 at 17:48
  • Why isn't it easy to find the feature that matches the time where you stop? You can find a feature that with a certain attribute value by using the search function, or sorting the attribute table by the time field and scroll to the time you stopped at, or selecting by attribute. – csk Dec 14 '18 at 21:06
  • Answer updated. And yes, you always can Select Features by Expression. – Gabriel De Luca Dec 14 '18 at 23:15
  • 1
    i confirmed shapefile layer are editable when loaded in timemanger in version 3.4.2 – paugam Dec 17 '18 at 17:51

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.