1

I seem to be unable to replicate actions with GRASS tools when I access them through QGIS 3.4. In particular the r.slope tool. I receive error messages and it fails in QGIS 3.4. They seem to work fine when accessed via QGIS 2.18. Is QGIS 3.4 known for such issues? I run Windows 10.

***2018-12-18T00:08:30     CRITICAL    Traceback (most recent call last):
          File "C:/PROGRA~1/QGIS 3.4/apps/qgis/./python/plugins\processing\algs\grass7\Grass7Algorithm.py", line 413, in processAlgorithm
          Grass7Utils.executeGrass(self.commands, feedback, self.outputCommands)
          File "C:/PROGRA~1/QGIS 3.4/apps/qgis/./python/plugins\processing\algs\grass7\Grass7Utils.py", line 411, in executeGrass
          startupinfo=si if isWindows() else None
          File "C:\PROGRA~1\QGIS 3.4\apps\Python37\lib\subprocess.py", line 756, in __init__
          restore_signals, start_new_session)
          File "C:\PROGRA~1\QGIS 3.4\apps\Python37\lib\subprocess.py", line 1155, in _execute_child
          startupinfo)
          OSError: [WinError 87] The parameter is incorrect***
  • 1
    Check this answer that may be useful. Please add the error log in the question. – Gabriel De Luca Dec 17 '18 at 23:47
  • 1
    That error was reported affecting vector GRASS tools of QGIS 3.4.0 on multi layer source files, but already solved. But your error is generated under different conditions (raster layer and QGIS 3.4.2)? The tool that fails is r.slope.aspect? (There is no GRASS tool called only r.slope). I do not have that error in QGIS 3.4.2.. Can you re-produce it in a new project and loading a single raster layer? – Gabriel De Luca Dec 18 '18 at 0:56
  • 1
    If it's not a problem with the raster files, I'd think it's a problem updating the libraries. Probably those of GRASS. I run QGIS Desktop 3.4.2 with GRASS 7.4.2 on a Win10 64bits machine and I have no errors in the GRASS tools, at least with the raster files that I am working with. I installed it from the OSGeo4W Network Installer downloaded from the QGIS website. If you want you can try a new clean installation to see if the problem is solved. – Gabriel De Luca Dec 18 '18 at 10:06
  • 2
    Yes. All is fine with that raster, I can process its slope. But I'm running the qgis-bin-g7.exe file, and I would think that you are running the qgis-bin.exe file. Serach for the bin folder. You need to run QGIS with GRASS . – Gabriel De Luca Dec 22 '18 at 20:36
  • 1
    As an alternative, try the OSGEO4w -non-standalone- Setup to get QGIS, GRASS and SAGA in a folder without blanks in paths. – AndreJ Dec 24 '18 at 15:06

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.