We have a web map application that uses a Geocortex viewer and references feature services on AGOL. Users get into the site with Active Directory credentials. When a user tries to update a record they receive the following error:

There was a workflow error running activity: Exception has been thrown by the target of an invocation.
Workflow 'Update Manhole Inspections Workflow' failed
Unhandled exception: 'One or more errors occurred.' in activity '1.396: Query for Feature'.
One or more errors occurred.
Error processing task results.
The request was aborted: Could not create SSL/TLS secure channel.

We've patched over our ArcGIS desktop installations with the TLS 1.2 patch but haven't published anything to AGOL since. Any ideas why this is happening?

2 Answers 2


How does your Geocortex workflow "Update Manhole Inspections Workflow" update the AGOL featureclass?
The error "Could not create SSL/TLS secure channel" could be caused by the Geocortex's inability to communicate on ports :443.

The best trouble-shooting technique is to test every bit in isolation. Create the simplest Geocortex workflow possible, doing an attribute update on a feature that is stored on AGOL. hard-code all the values so there are no surprises, and Validate that it works.

Isolate each segment of communication and test them bit by bit.

// poliart . com


An old question, but I'll add this answer anyway, it may help others.

Given the date of the original question, I'll assume that it is about Geocortex Essentials / Workflow 4.x. BTW, in this case the error is caused by a Query Task, not Update Features. The solution is the same though.

This error message is usually caused by a client (the machine the Geocortex is running on) not being able to connect to a server (ArcGIS Online) because there's a mismatch between supported TLS versions. You didn't mention the Windows version, but presumably it is configured for TLS 1.0 and 1.1, while ArcGIS is configured for TLS 1.2 only.

What you need to do is apply the TLS 1.2 patch to the Geocortex machine(s), because that is where the Query Task activity is executed. Then, restart the Geocortex Core service and / or the relevant Geocortex application pools in IIS.

See also: https://docs.microsoft.com/en-us/mem/configmgr/core/plan-design/security/enable-tls-1-2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.