1

1) A few days ago, I run "clip" tool on some shapefile.

enter image description here

Green shapefile was obviously full of the area, but after clip process, some regions are lose their area...

Why does this error occur?

2) I edit shapefile in QGIS, for example... In editing mode, I'm edited some object use by tool like "divide object" & "merge selected object"

Before editing, shapefile show me image like lower jpg.

enter image description here

But after editing... QGIS show me image like below jpg.

enter image description here

Result contain sliver...

I run same process in ArcMap, and ArcMap give me a correct result...

Is it just an error in QGIS?

closed as unclear what you're asking by ahmadhanb, Hornbydd, Andre Silva, csk, Jochen Schwarze Jan 7 at 11:44

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

1

May be your layers has topological errors. Try to repair your layer before any geoprocessing ( Processing toolbox Ctrl + Alt+ T -> Fix geometries)

Not the answer you're looking for? Browse other questions tagged or ask your own question.