Reinstalling QGIS on Linux Mint?

Most of my recent troubles are documented in the thread above, and I wasn't sure if I should just post this there. But here I am.

It just stopped working. It won't start. I hadn't used it in a few months and when I tried, nothing. I don't have a clue where to begin

Mint Cinnamon 17.3 64-bi kernel 3.13.0-37-generic x86_64 (64 bit)

When I run it from command line I get:

ThinkPad-T410 ~ $ qgis
/usr/bin/qgis.bin: error while loading shared libraries: libltidsdk.so: cannot open shared object file: No such file or directory

Edit 2: OK, I'm not sure I quite understand this but this is what I did and this is what I got:

$ ls /usr/lib/*libltidsdk*
ls: cannot access /usr/lib/*libltidsdk*: No such file or directory
  • 1
    Launch it from command line, you will have some outputs. – etrimaille Dec 22 '18 at 21:46
  • 1
    Did you try to install GDAL with MrSID support? – AndreJ Dec 23 '18 at 16:30
  • I dont recall trying to install Gdal, nor do I know how. I gave up on viewing orthos in Linux. When I need orthos I switch over and use Windows with Q 3.something. I suppose I could try again since at this point, I have no Q to lose... – Bad medicine Dec 23 '18 at 17:24
  • 1
    Responding to your edit: ls /usr/lib/libltidsdk will list all files within the directory. But libltidsdk does not exist. Try ls /usr/lib/*libltidsdk* which will list all files withing /usr/lib/ that contain libltidsdk. – Hayden Elza Dec 23 '18 at 18:40
  • Ah, I didn't realize in your second edit that the asterisks were there. I edited your post to format the code. – Hayden Elza Dec 23 '18 at 19:56

Since your attempt to install MrSID "did not end well", you should get rid of the self-compiled stuff.

It might be that your OS is too old to support current the LizardTech codebase. So remove everything that is self-compiled, and install GDAL and QGIS 2.14 from the ubuntugis-unstable ppa as long as they support trusty. If that works, upgrade to QGIS 2.18 from https://qgis.org/ubuntugis

If you need MrSID support, install a more recent Linux Mint in a virtual box, and test the self-compiling there. If it works, think of upgrading your OS.

  • Yeah i think will just pass on doing anything. I will be getting ArcGis shortly for a class I'm taking, and MrSid already works on the Windows QGIS side. So I think I'll just wait until I get a new laptop and new Mint sometime later next year. – Bad medicine Dec 25 '18 at 17:07

libltidsdk.so is a dependency. It should be a symbolic link to the current version called something like libltidsdk.so.20.0.0. If the symbolic link was broken during an update you can relink it using a method similar to here. Instead of libgdal.so figure out the needed link for libltidsdk.so.

In my experience, dependencies break here and there for qgis and this method always seems to do the trick.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.