2

I have installed GeoPandas and its dependencies using pip install package_name. Here is the pip list output:

Package Version


attrs 18.2.0
Click 7.0
click-plugins 1.0.4
cligj 0.5.0
cycler 0.10.0
descartes 1.1.0
Fiona 1.8.4
geographiclib 1.49
geopandas 0.4.0
geopy 1.18.1
kiwisolver 1.0.1
matplotlib 2.2.3
munch 2.3.2
numpy 1.15.4
pandas 0.22.0
pip 18.1
psycopg2 2.7.6.1
pyparsing 2.3.0
pyproj 1.9.5.1
PySAL 1.14.4.post2 python-dateutil 2.7.5
pytz 2018.7
Rtree 0.8.3
scipy 1.2.0
setuptools 40.6.3
Shapely 1.6.4.post2 six 1.12.0
wheel 0.32.3

But as soon as i am importing it in Python console as

import geopandas

I am getting an error as

Traceback (most recent call last): File "", line 1, in File "/home/rajesh/panda_projects/env/lib/python3.4/site-packages/geopandas/init.py", line 1, in from geopandas.geoseries import GeoSeries File "/home/rajesh/panda_projects/env/lib/python3.4/site-packages/geopandas/geoseries.py", line 5, in from pandas import Series File "/home/rajesh/panda_projects/env/lib/python3.4/site-packages/pandas/init.py", line 26, in from pandas._libs import (hashtable as _hashtable, File "/home/rajesh/panda_projects/env/lib/python3.4/site-packages/pandas/_libs/init.py", line 4, in from .tslib import iNaT, NaT, Timestamp, Timedelta, OutOfBoundsDatetime File "pandas/_libs/src/numpy.pxd", line 865, in init pandas._libs.tslib ValueError: numpy.ufunc has the wrong size, try recompiling. Expected 192, got 216

What is the solution for this?

  • When you start the Python console, what version is reported? – Marc Pfister Dec 27 '18 at 18:51
  • python version is 'Python 3.4.3 (default, Nov 17 2016, 01:08:31) [GCC 4.8.4] on linux Type "help", "copyright", "credits" or "license" for more information.' – Rajesh Kumar Dec 28 '18 at 7:49
  • 1
  • Thanks i just reinstalled the pandas version compatible with python 3.4.3 and isuue is resolved now – Rajesh Kumar Dec 29 '18 at 8:24
2

With tag python-3 in your question so you need pip3 instead pip. Package pip3, in Debian, is in python3-pip. Search for equivalent if you use a Debian based distro or another Linux distro. Afterward, install geopandas with:

pip3 install geopandas

At following image of QGIS 3 Python Console, it can be observed geopandas imported without any error:

enter image description here

Editing Note:

Install equivalent of following packages in your system and try again with geopandas.

sudo apt-get install build-essential python-dev libgdal-dev
  • i tried to reinstall it with pip3 but same error.. using python3.4.3 version – Rajesh Kumar Dec 28 '18 at 8:00
  • Wich Linux do you have? – xunilk Dec 28 '18 at 8:55
  • ubuntu 14.04LTS – Rajesh Kumar Dec 28 '18 at 9:43
  • Ok.Wait a moment and, please, see Editing Note in my answer. – xunilk Dec 28 '18 at 12:34
  • Thank you so much for guiding me. I solved my issue with reinstalling pandas as it was not compatible with python 3.4.3 version after removal of current version. So just ran the command pip3 install 'pandas<0.21' and issue is resolved now. – Rajesh Kumar Dec 29 '18 at 8:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.