0

I'm using QGIS version 3.4.1 with a Windows 10 OS. I'm trying to edit an Esri FGDB folder. Haven't succeeded. So far so I'm using a workaround: exporting specific layer to a new FGDB - with 'Save Feature As...' - and then editing.

This lets me edit but creates a new OBJECTID column. This column is sequential and does NOT correspond with the original table's OBJECTID.

How can I retain the old layer's fields schema (i.e. only one OBJECTID column) with the same values as the original imported layer?

Things I've tried:

  1. Field calculator -

enter image description here

  1. Leaving a blank space inside the 'Save Feature As...' FID option -

enter image description here

  • 2
    You cannot control the objectid column contents. You can create a new integer NOT NULL column named orig_id and populate that. – Vince Dec 30 '18 at 13:26
  • The default GDB driver compiled into QGIS/OGR is the OpenFileGDB driver which is read-only. It is not the Esri-Licensed FileGDB driver which has read/write support (for most but not all of ArcGIS' GDB objects). – Ralph Tee Jan 5 at 5:32

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.