0

Using apt-get install, I've added the following packages:

postgis/bionic-pgdg,now 2.5.1+dfsg-1.pgdg18.04+1 amd64 [installed]
postgis-doc/bionic-pgdg,now 2.5.1+dfsg-1.pgdg18.04+1 all [installed,automatic]
postgresql-10/bionic-pgdg,now 10.6-1.pgdg18.04+1 amd64 [installed]
postgresql-10-ogr-fdw/bionic-pgdg,now 1.0.7-2.pgdg18.04+2 amd64 [installed]
postgresql-10-pgrouting/bionic-pgdg,now 2.6.1-2.pgdg18.04+2 amd64 [installed]
postgresql-10-pgrouting-scripts/bionic-pgdg,now 2.6.1-2.pgdg18.04+2 all [installed]
postgresql-10-postgis-2.4/bionic-pgdg,now 2.4.4+dfsg-4.pgdg18.04+1 amd64 [installed]
postgresql-10-postgis-2.4-scripts/bionic-pgdg,now 2.4.4+dfsg-4.pgdg18.04+1 all [installed]
postgresql-10-postgis-2.5/bionic-pgdg,now 2.5.1+dfsg-1.pgdg18.04+1 amd64 [installed,automatic]

I've also added the following GEOS packages using apt-get:

libgeos++-dev/bionic,now 3.6.2-1build2 amd64 [installed]
libgeos-3.6.2/bionic,now 3.6.2-1build2 amd64 [installed]
libgeos-c1v5/bionic,now 3.6.2-1build2 amd64 [installed]
libgeos-dev/bionic,now 3.6.2-1build2 amd64 [installed]
libgeos-doc/bionic,now 3.6.2-1build2 all [installed]

I then try to use psql and add PostGIS with the following call:

CREATE EXTENSION IF NOT EXISTS postgis WITH SCHEMA public;

But I'm given an error message:

ERROR: could not load library "/usr/lib/postgresql/10/lib/postgis-2.4.so": /usr/lib/postgresql/10/lib/postgis-2.4.so: undefined symbol: GEOSMinimumClearance

I ran into the same type of GEOS error when I tried installing Postgresql 11 & PostGIS. I assume that the PostGIS library is not finding the Geos. What should I be doing with the packages to make things work? I didn't want to download and build from source files which is what most of the older online instructions show. I'm pretty bad with Linux setup, so I'm hoping it's an easy solution.

  • This sort of question shows up quite often. The cause is usually due to having installed different version of Postgres, Postigs, Geos, etc, on top of each other and/or some combo of compiling from source vs packages. It usually comes down to a missing symlink or needing to run ldconfig. – John Powell Jan 2 at 14:52

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.