I am running the nearest neighbour algorithm in QGIS 3.4.3. enter image description here

I have tried various parameters but the problem persists. I have also tried other algorithms (simple Kriging) and had the same problem. However, I did succed running the IDW interpolation algorithm from the QGIS plugin itself.

this is the message log :

enter image description here

  • 1
    That field name looks very odd... is it correct? – ndawson Jan 2 '19 at 23:02
  • @ndawson yes, the field title is strange, maybe because I worked on the project using a different version of QGIS, but its contents are real numbers to 5 d.p. ranging from 15 to 21. I re-installed QGIS using OSGeo4W, and I am having no problems, all the interpolation tools of SAGA are working fine! – Daniel Spiteri Jan 3 '19 at 9:27
  • looks like gis.stackexchange.com/questions/302457/… – Mike Jan 3 '19 at 15:13
  • Please show the lines of code around the line 113 from the file SagaUtils.py – Mike Jan 3 '19 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.