0

I am trying to build GeoServer using Maven. I followed the instructions from the GeoServer website Instruction from GeoServer site. When i get to the build stage it fails. I have tried to search for cases where this happened but not been able to find any solutions. In the error reads Invalid escape character at line 1...... attached is a screen shot of the error.

Error message

I am using Windows 10, apache-maven3.6.0 bin. Any ideas on how to solve this?

5
  • Pretty much all the GeoServer devs use a unix system for development so not much chance of any help I'm afraid. However the build is tested using AppVeyor so it should work. – Ian Turton Jan 5 '19 at 11:11
  • I could try in a virtual environment to see if it would work.. So far i have tried different approaches and i have not been successful I was also wondering maybe it might be the version of maven. – mapperx Jan 5 '19 at 11:43
  • 1
    Please do not provide pictures of errors, which are neither legible on all devices nor searchable; instead include the actual text as ASCII in the body of the question. – Vince Jan 5 '19 at 12:28
  • I'm currently using mvn 3.6.0 and Java 1.8.0_191 are what I'm currently using – Ian Turton Jan 5 '19 at 15:08
  • Looking at the error, it seems more of a file encoding issue. How did you get the sources? If it's git, I'd check its checkout options. – Andrea Aime Jan 7 '19 at 9:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.