4

I am coming from ArcMap. Working in the layout view, I had buttons to zoom/pan data and other buttons to zoom/pan the view itself. In QGIS, I can't seem to be able to achieve this. The only buttons I have are for zooming/panning the view not the data(the same happens when I use the mouse scroll wheel).

Any way to achieve this?

  • 1
    At 3.8.2, the ONLY way that I can zoom in/out the data is to manually type in a scale value in the Map's Item Properties > Main Properties > Scale. ALL of the Zoom buttons (eg those with any sort of a magnifying glass appearance) act on the view, not the data. – Stu Smith Sep 2 '19 at 20:49
10

You can pan the map by first selecting it. Then using the "Move item content" tool:

enter image description here

While this tool is active as well you can also use the mouse wheel to zoom in and out on the map.

| improve this answer | |
  • 1
    No, this tool moves the whole map. I want to pan/zoom only the data. – Faustin Gashakamba Jan 10 '19 at 11:19
  • That tool DOES pan and zoom the data. You are probably using the tool one to the left. – HeikkiVesanto Jan 11 '19 at 14:03
8

You just have to use the "Move item content" tool

enter image description here

| improve this answer | |
  • This tool works, but if you have a rectangle surrounding the map, it does nothing. It seems to pick the rectangle and I could not get it to pick the map. After I unchecked the rectangle in the layout, turning it off, it worked as expected. – malcolm Apr 24 '19 at 13:54
  • like @malcom I couldn't get the map content to move. I'd select the "Move item content" tool but clicking and dragging had no effect. After a long time I figured out the map frame was locked. So try Items >> Unlock All (Ctrl-Shift-L) if this happens to you too. – matt wilkie Jun 19 at 4:54
5

There are a series of buttons under Item Properties that allow you to zoom in on data in map. I just had success using the leftmost button (in orange rectangle) "Set Map Extent to Match Main Canvas Extent."

The process looks like this 1. In main QGIS window, zoom to extent you want to use in Print Layout. 2. In Print Layout window, click "Set Map Extent to Match Main Canvas Extent" 3. See if Print Layout looks ok. If not, repeats steps 1 and 2 until you are satisfied.

"Move Item Content" button (blue square) did not work for me. It only repositioned the map inside the layout.

I did have some success with "Interactively Edit Map Content" button (green square) but it zoomed too much with one mouse wheel scroll. Green button and blue button have the same logo which is confusing.

I am using QGIS 3.8.3-Zanzibar

QGIS screenshot highlighting map extent tools

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.