I have a grid in ArcGIS Pro that I've named the X and Y axis (in separate columns) and am now trying to do a field calculation on the total grid name (I've tried using both single and double quotes. I've tried using just a space, to test if maybe I needed an escape character):

!XAxis! + '-' + !YAxis!

!XAxis! + "-" + !YAxis!

enter image description here

I don't receive an error, but I don't receive any results in my table (and yes, I have refreshed multiple times and multiple minutes after running the script, knowing that sometimes there seems to be a lag in Pro)

enter image description here

I've used the verification at the bottom of the screen to test my syntax and it comes out clean. No errors on run, in fact, it states that it is running successfully:

enter image description here

I've double checked my work against Esri articles and other things I've found online... https://support.esri.com/en/technical-article/000018207

I know that there are still a few odd bugs with Pro, but I'm hoping to find a work around (other than opening up Desktop and solving it there).

I have used a Field Calculation earlier in this exact same table to swap the X and Y axis values, when I saw that the labels did not match reality. So it's not that I don't have permissions to the table or anything like that.

All three fields I am working with (XAxis, YAxis and GridLocation) are all text fields with X & Y having field lengths of 5 (even though none are above 2 characters) and GridLocation having a field length of 15 (even though the calculation would never put the length above 11, even if both the other fields were maxed out).

  • Try "{0}-{1}".format(!XAxis!,!YAxis!)
    – Bera
    Commented Jan 9, 2019 at 16:00
  • Same results. :/
    – MaryBeth
    Commented Jan 9, 2019 at 16:10
  • What happens if you just put a single string in, such as 'foobar'
    – toslund
    Commented Jan 9, 2019 at 16:12
  • Also, this is a long shot but.. do you have another field with the same Alias? It's possible to calculate a field with the field name "GridLocation" and alias "GridLocation" but be looking for the result in a field appearing to be "GridLocation" (alias) but actually be named "SomethingElse"
    – toslund
    Commented Jan 9, 2019 at 16:20
  • 1
    I think you should self-answer based on your last few comments.
    – PolyGeo
    Commented Jan 9, 2019 at 19:35

1 Answer 1


Deleting the field and recreating it worked for me. Never was able to get to the root of the problem, but a lot of things to look into if you run into a similar issue (see below).

Other things to attempt if you run into the same issue:

*Look to see if you have the same alias assigned to another field

*Make sure that you do not have records selected and the calculation is occurring on those rows

*Make sure the field is not read-only

*Check your permissions for the table/feature/etc

*Double check your syntax

*Fields are of the correct type and you are not trying to add an integer to a string, etc. Also, field lengths are able to handle the concatenated value.

*Restart Pro to see if you can reset whatever may be causing this

*Delete the field and re-create if all else fails

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.