0

I am trying to install the GDAL plugin for Geoserver on machines which have windows 7 and 10.
both machines had a previously installed version of OSGeo4W.

I followed all the instructions in the official Geoserver guide,
but it seems to be outdated as it recommends using gdal versions that work with Microsoft Visual C++ Redistributables which my machines don't have (i have the minimal 2015 while the most recent version in the downloads page is 2010).

After unziping the *.jar files to the WEB-INF/lib folder, making sure that the GDAL_DATA variable is defined properly and making sure that the new GDAL version i installed is first on the PATH variable and added the GDAL_DRIVER_PATH variable to link to the ECW and MrSID *.dll's i still can't see the ECW format when i try to open a new data store in Geoserver (Yes, after restarting), I also copied the GDAL *.dll files to wrapper/lib folder as suggested here.

Is there some step I am missing?
Is there a way for Geoserver to recognize OSGEO4W's GDAL version and extensions?
I want to keep using the OSGeo4W version of QGIS since it contains the filegdb write option which i can't get to work in the other installment of QGIS.

UPDATE
Tested other plugins which seem to be working well, also tested that gdalinfo is using the 1.9.2 version that Geoserver needs to use and that it has ECW format support.
Still not working.

  • GeoServer requires a specific version of GDAL which may not be the one installed by OSGeo4W – Ian Turton Jan 10 at 8:55
  • which is why i pointed it to the version the guide instructed me to install and placed that version first on the path – Dror Bogin Jan 10 at 8:56
  • @IanTurton still doesn't work after removing all other GDAL versions from path and making sure that version 1.9.2 is used and ECW is recognized format with gdalinfo – Dror Bogin Jan 10 at 9:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.