0

When I start qgis with the terminal I get the following error:

QGIS died on signal 11[New LWP 15278] [New LWP 15279] [New LWP 15280] [New LWP 15283] [New LWP 15284] [New LWP 15286] [New LWP 15292] [Thread debugging using libthread_db enabled] Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1". 0x00007fa1f82b96c2 in __GI___waitpid (pid=15293, stat_loc=0x7fff74e3b6ac, options=0) at ../sysdeps/unix/sysv/linux/waitpid.c:30 30   ../sysdeps/unix/sysv/linux/waitpid.c: No such file or directory. [Current thread is 1 (Thread 0x7fa1fc1a5980 (LWP 15275))]
#0  0x00007fa1f82b96c2 in __GI___waitpid (pid=15293, stat_loc=0x7fff74e3b6ac, options=0) at ../sysdeps/unix/sysv/linux/waitpid.c:30
        resultvar = 18446744073709551104
        sc_cancel_oldtype = 0
#1  0x000055c5eb4217ce in  ()
#2  0x00007fa1f8213f20 in <signal handler called> () at /lib/x86_64-linux-gnu/libc.so.6
#3  0x00007fa1f835a5ab in __strncmp_sse42 () at ../sysdeps/x86_64/multiarch/strcmp-sse42.S:270
#4  0x00007fa1ec4b5d77 in pj_param_exists () at /usr/lib/x86_64-linux-gnu/libproj.so.13
#5  0x00007fa1ec4c99b4 in proj_create () at /usr/lib/x86_64-linux-gnu/libproj.so.13
#6  0x00007fa1f6dd8a67 in  () at /usr/lib/libgdal.so.20
#7  0x00007fa1f6dc8520 in OGRSpatialReference::importFromProj4(char const*) () at /usr/lib/libgdal.so.20
#8  0x00007fa1fa957244 in QgsCoordinateReferenceSystem::setProj4String(QString const&) () at /usr/lib/libqgis_core.so.3.4.3
#9  0x00007fa1fa95a2e5 in QgsCoordinateReferenceSystem::createFromProj4(QString const&) () at /usr/lib/libqgis_core.so.3.4.3
#10 0x00007fa1fa95b01c in QgsCoordinateReferenceSystem::fromProj4(QString const&) () at /usr/lib/libqgis_core.so.3.4.3
#11 0x00007fa1fa9a7f40 in QgsEllipsoidUtils::ellipsoidParameters(QString const&) () at /usr/lib/libqgis_core.so.3.4.3
#12 0x00007fa1faa6cfbb in QgsMapSettings::setEllipsoid(QString const&) () at /usr/lib/libqgis_core.so.3.4.3
#13 0x00007fa1f649071a in  () at /usr/lib/libqgis_gui.so.3.4.3
#14 0x00007fa1f8e206cf in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#15 0x00007fa1faf44845 in QgsProject::ellipsoidChanged(QString const&) () at /usr/lib/libqgis_core.so.3.4.3
#16 0x00007fa1faaf48db in QgsProject::setEllipsoid(QString const&) () at /usr/lib/libqgis_core.so.3.4.3
#17 0x00007fa1fb601172 in QgisApp::fileNew(bool, bool) () at /usr/lib/libqgis_app.so.3.4.3
#18 0x00007fa1fb615e92 in QgisApp::QgisApp(QSplashScreen*, bool, bool, QString const&, QString const&, QWidget*, QFlags<Qt::WindowType>) () at /usr/lib/libqgis_app.so.3.4.3
#19 0x000055c5eb41d5d5 in  ()
#20 0x00007fa1f81f6b97 in __libc_start_main (main=0x55c5eb41b760, argc=1, argv=0x7fff74e3d998, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff74e3d988) at ../csu/libc-start.c:310
        result = <optimized out>
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {0, -8979781846726237085, 94308543893936, 140735154477456, 0, 0, -2948634281101908893, -2906720311133100957}, mask_was_saved = 0}}, priv = {pad = {0x0, 0x0, 0x7fa1fc013733 <_dl_init+259>, 0x7fa1fbfd1538}, data = {prev = 0x0, cleanup = 0x0, canceltype =
-67029197}}}
        not_first_call = <optimized out>
#21 0x000055c5eb4211da in _start () gdb returned 0 Aborted`

No idea what is happening.

I had some problems in the installation, I had to create a fake gdal-abi-2-2-3 package and had to install grass-core_7.4.0-1_amd64 instead of grass-core_7.4.3 for dependency problems with Virtual package grass740.

2

I had no issue installing on 18.04 using the instructions at http://qgis.org.

/etc/apt/sources

deb https://qgis.org/debian bionic main # disabled on upgrade to bionic
deb-src https://qgis.org/debian bionic main # disabled on upgrade to bionic

then

sudo update
sudo upgrade
sudo apt-get install qgis python-qgis qgis-plugin-grass

and all was fine, including gdal and grass.

$ apt list gdal-*
Listing... Done
gdal-bin/bionic,bionic,now 2.2.3+dfsg-2 amd64 [installed]
gdal-data/bionic,bionic,bionic,bionic,now 2.2.3+dfsg-2 all [installed]
$ apt list grass 
Listing... Done
grass/bionic,bionic,bionic,bionic 7.4.0-1 all
$ apt list grass-core
Listing... Done
grass-core/bionic,bionic,now 7.4.0-1 amd64 [installed,automatic]
  • Yes, I first tried with these instructions, but I got the errors above commented. :( – R. Curcoll Jan 10 at 16:33
  • try apt purge grass qgis gdal before you start – Ian Turton Jan 10 at 16:41

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.