2

I have just created a date field attribute.

In Proprieties > Fields of the layer I made this:

Result1

And the attribute tables shows this:

Result2

What I want to see is the date in this format: 07-01-2019 and not 2019-01-27.

What do I need to do to have a permanent solution?

  • That's how date are stored in the field. You can enter your data in edit mode as DD-MM-YYYY and If you identify the point, the data will be seen as DD-MM-YYYY – Vale Jan 11 at 9:33
3

Bring back Field Format to default (yyyy-MM-dd) setting and customize the Widget Display only.

enter image description here

  • Thanks, It works when you have QGIS opened, but if you remove and add your layer the format change to the default format. – Paulo Martinho Jan 11 at 9:43
  • @PauloMartinho If you need a permanent change in the date display setting, make sure to state it in your question. – Kazuhito Jan 11 at 10:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.