1

I am trying to install the ArcGIS Runtime SDK for .NET using Visual Studio 2015 (I see that it is not supported yet for VS 2017, so I installed 2015). I am follwing the ESRI documentation but having issues. I downloaded and installed the Runtime SDK (100.30) on my local and then opened my Visual Studio 2015. I am not seeing any of the Esri/ArcGIS templates under projects so I opened an existing solution; an AddIn, and tried using nuGet to download the package (I searched for ArcGIS Runitme SDK). I got the following error: "Could not install package Esri.ArcGISRuntime 100.30. You are trying to install this package into a project that targets '.NETFramework, Version=v3.5' but the package does not contain any assembly references or content files that are compatible with that framework." What am I doing wrong here? enter image description here

3

I see that it is not supported yet for VS 2017

VS2017 is supported. The latest release dropped support for VS2015, albeit you can still use the NuGet packages from nuget.org in VS2015 (all the installer does is add some starter-templates and creates a local nuget repository).

The issue you're hitting is you're targeting a very old version of .NET. You need to target at least .NET 4.6.1. Change your project to target a newer version of .NET Framework, and you should be fine.

  • Yeah, it looks like the target was pointing to V 3.5.1 for some reason (I apparently have multiple versions of .NET framework. – gwydion93 Jan 14 at 15:42

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.