1

I have a map I've made in QGIS which is points from a .csv file. These have then be turned into different symbols based on what they represent and then the sizes of said symbols based on values in the .csv.

I need to export this as a .dxf to use in AutoCAD so it basically looks the same as it does in QGIS. However, when I do so it just exports as single dots (points). Is there a way I can export them as the symbols as I can see in QGIS?

  • Did you check this post? gis.stackexchange.com/questions/244192/… – Mat Jan 13 at 21:44
  • I have looked at that post I think they are using polygons they have created themselves and exporting them as a .dxf. What I am trying to do is export a point that is represented as a symbol (e.g. a star). I want to see the star when I export as a .dxf but I just seem to be able to get points. Is it possible to convert symbols to polygons in QGIS and do it that was around? – Wiredchild Jan 14 at 13:08
2

To export symbols not only geometry do not use Export layer but Project > Export > Export project to DXF:

enter image description here

enter image description here

  • Oh, I've just tried this and it doesn't export anything at all? As in the dxf is completely empty. I have uploaded an image of my map here: imgur.com/a/ACSXFLB I want it to appear in AutoCAD as it does in GIS with all the shapes, not points. – Wiredchild Jan 19 at 13:54
  • I used this metod before, just tried it again now and it works. You sure dxf is empty? Try importing dxf back to qgis to see if its actualy empty. – Mat Jan 19 at 19:55
  • In AutoCAD you could try ctrl+a to see if it selects any elements if it does, change color... if its actually empty, you maybe didn`t use correct settings. Try some options, maybe upload printscreen of Export settings.. – Mat Jan 19 at 20:03
  • There's pictures of my output on QGIS and the resulting .dxf in AutoCAD imgur.com/dd9Ik5k imgur.com/JLMkUWe Sorry, i don't know how to embed the images in the page like you've done. I've noticed the dots in AutoCAD aren't dots they are symbols (hexagons, diamonds, squares etc like in the image but they are absolutely tiny and don't relate size-wise like in QGIS. I put the symbology scale at 1:1? Is this correct? Thanks for the help! – Wiredchild Jan 19 at 20:27
  • Aha, This does work in QGIS 2.18. but it seems in QGIS 3 someting is wrong with export sizes. Changing scale seems to not have any effect. Whatever units you use for symbols, it will take them as meters. So, or use Qgis 2.18 or somehow use meters for symbol sizes. I`ll check if this bug should still be reported.. – Mat Jan 19 at 21:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.