I made one Atlas Map based on this exercise (https://anitagraser.com/2016/10/15/qgis-atlas-tutorial-material-design/) and I had good results working with QGIS 2.18.

But when I use QGIS 3.4 I can not get the same results.

As you can see in this picture bellow in QGIS 2.18 I have this notification when I run the filter test:

enter image description here

This is what happens when I run the same filter code in QGIS 3.4:

enter image description here

Filter expression parsing error:

$atlasfeatureid function is not known

$map function is not known

So in this case - What do I need to do?


1 Answer 1


Tutorial might be for earlier version of QGIS, wrong syntax is used. The right syntax (in QGIS 3.4) is:

1st rule - $id=@atlas_featurenumber AND @map_id='ZOOM'

2nd rule - @map_id='GENERAL'

3th rule - $id= @atlas_featurenumber AND @map_id='GENERAL'

You can use search in Expression string builder to get the right syntax if not sure about it:

enter image description here

  • +1 for using the Expression builder to help with syntax.
    – csk
    Jan 15, 2019 at 17:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.