2

I was testing joining a dataset to shapefiles in Qgis. The text file that I used in my earlier testing as my csvt file worked perfectly and I was able to create gradient maps using my joined dataset. However, I have now moved the exact same dataset and the exact same csvt file over to another map in a different project. I joined the dataset to this map in exactly the same way with the csvt file in the same folder, just as before, but I am no longer able to create gradients using the data from the dataset. Specifically when I try to select the column to use for the gradient it should (and did) list 22 different variable options which are floats, now it does not list any as options. I have not changed anything in the text file, nor the dataset, so I have been unable to figure out why this worked fine earlier and no longer does.

Screen shot of Qgis project and csvt text file

1

Your csvt is not working because it does have a txt extension also (see your attached image) . In windows explorer activate view file extensions and erase the .txt. That should work

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.