1

I have a link field in a feature layer on AGOL. I want to link to files that reside on my desktop. When I click on the link nothing happens. If I copy the link to IE or Chrome, I get a search page list of options, not the file I want. This is a sample link that I am trying to use: "file:\aiotxtem3fp1\geodata$\elevation\Texas_Lidar_1m\Rasters\Texas_Lidar\USGS_NED_ArcherJack_1m_2014\USGS_NED_one_meter_x50y370_TX_Archer_Jack_2014_IMG_2016". The word "file" preceding the link is recommended by ESRI. I set this configuration up last July and this link worked perfectly: "\aiotxtem3fp1\geodata$\elevation\Texas_Lidar_1m\Rasters\Texas_Lidar\USGS_NED_ArcherJack_1m_2014\USGS_NED_one_meter_x50y370_TX_Archer_Jack_2014_IMG_2016" before the newest upgrade in AGOL and Windows 10. Any ideas or suggestions as to the problem or a solution. I don't have access to a server to put my files on.

1

This is not possible. Check out the support article to learn more: https://support.esri.com/en/technical-article/000012221

| improve this answer | |
0

An alternative to directly linking from a local drive is to upload the file for ArcGIS Online to host in a field. To do this, enable image attachments for the layer from the item details page:

Image Attachment

Thereafter, you should open the item in the Map Viewer, open its attribute table, and scroll horizontally to the end to find a new field called 'Photos and Files'. You'll be able to upload images from your desktop through the 'Add' button (or the 'Show' button after you've added some images).

Add Images

Don't forget to save the layer when you're done.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.